The Nut House

  • Welcome, Guest. Please login.
 

Help modding a sound ?

Started by b51bomber, Feb 12, 2016, 12:51 am

previous topic - next topic
Go Down

b51bomber

Feb 12, 2016, 12:51 am Last Edit: Feb 12, 2016, 12:53 am by b51bomber
Hi, I'm trying to replace the default coin/cash register sound but can't seem to make it work in game sqrlFAIL  I will upload a copy of the sound file so someone can try to see what I'm doing wrong.   

https://drive.google.com/file/d/0B1pQwBkD-BZwa0JfdXIwQ2p6d0U/view?usp=sharing

Thanks in advance :P

carlitosbahia

#1
Feb 12, 2016, 02:56 am Last Edit: Feb 12, 2016, 02:58 am by carlitosbahia
Hi

1) the file format seems to be ok, needs to be .ogg

2) Check that you have the right folders , complete path for the coin sound is sound/ui/coin.ogg , i guess you already know this if you are trying to mod but just in case remember to take the sound folder and all the content (folder, subfolder and sound file , not only the file) into winrar or winzip and using no compression (just store) with a scs extension

3) right now i am not totally sure if the coin/cash register is coin.ogg or money_4.ogg , one is the income money and the other is the loan payment sound



edit: if you upload your scs file also will help people open it and see what is wrong

b51bomber


carlitosbahia

after using that file for a bit this is what i think (could be wrong)

_ coin.ogg is the name of the file for when you pay the loan , your drivers give you some money and you pay for fuel
_ money_4 is the file for everything else (crash, red light, speed limits)

the folders inside the scs file are ok , but using the mod (coin.ogg) i don't get some sounds so i guess something is wrong with that ogg file (maybe some options when you save it, some not default format? ) , also audacity http://prntscr.com/a2cs6u shows me that scs audio files are mono and yours is stereo, try that too

b51bomber

 sqrlFAIL I have tried every thing I can think of to try an get this mod to work, I even took a look at Blackhawkso's creepy yawn mod to see if I could learn anything from it but it seems to be the same as what I have done so IDK what else to do?

carlitosbahia

yeah, i tried everything i could think, but i guess we can't mod these 2 sounds ... sqrlCRY 
found this on the bugs section of the scs forum, for ETS2 1.21 , must be the same issue in ATS
http://forum.scssoft.com/viewtopic.php?f=173&t=192224

Quote
FYI, these two sounds are part of UI. and UI must be loaded before profile (with its mods) is selected. therefore the game does not react to moded basic UI - its already in memory and running.
force mods param works directly at the start before anything is loaded (at the cost of loading all available mods).

i will look if anything can be done there.
http://forum.scssoft.com/viewtopic.php?f=123&t=192175&hilit=coin.ogg
http://forum.scssoft.com/viewtopic.php?f=41&t=187039&p=408093&hilit=coin.ogg#p408093

b51bomber

Thanks for all your help carlitosbahia, I got the mod to work by using the -force_mods parameter  ;D

Thanks again  ;D

Go Up